导读 LLVM编译器项目正在考虑更换许可证。LLVM项目目前使用的是类BSD的NCSA许可证,更换许可证的目的一则是降低贡献代码的门槛鼓励更多人参与,二则是提供更好的专利保护,三则是消除运行时库与编译器其余部分的分裂。

开发者提议采用Apache 2许可证和运行时例外条款。

llvm

在将近一年的讨论之后,LLVM社区总体上同意这一做法,但有一个担忧: 许多人认为Apache 2 许可证与GPLv2许可证不兼容,而很多重要的GPLv2(以及GPLv2+)项目使用了LLVM编译器。在与律师讨论过之后,LLVM项目计划采用Apache 2许可证,但将加入额外的例外去处理可能出现的GPLv2不兼容情况。

原文来自:http://www.cnbeta.com/articles/541101.htm

本文地址:http://www.linuxprobe.com/apache-license.html编辑:张庚,审核员:冯琪