导读 Java开发人员现在可以使用JDK 11运行Gradle构建。流行的开源构建自动化工具(Gradle 5.0)的最新里程碑版本还附带了一个可用于生产的Kotlin DSL、依赖版本校准和任务超时,以及长列表增强功能和升级。

在这个版本中,真正吸引眼球的是包含Kotlin DSL 1.0。Kotlin DSL(特定于域的语言)通过在受支持的ide中“增强的编辑体验”(根据Gradle Kotlin DSL入门)提供了传统Groovy DSL(最初是在Gradle最早的版本中引入的)的替代语法。Kotlin DSL目前完全支持两个ide: IntelliJ IDEA和Android Studio,但是其他集成开发环境可以导入并使用基于Kotlin-DSL的构建。

Gradle团队在一篇博客文章中说,使用Kotlin编写构建逻辑“在ide中提供了显著的额外编辑帮助,包括:改进的完成、错误突出显示和重构工具……”“如果您更喜欢Groovy的灵活性和动态特性,那完全可以——Groovy DSL不会被弃用,”他们补充说。

在Gradle 5.0中引入的依赖项版本对齐也是这个公告中的一个引人注目的地方。该功能允许属于同一逻辑“平台”或“一起工作”的模块集的不同模块,因为它们是作为一个整体发布的,或者因为测试显示它们是一起工作的,Gradle Docs页面对此进行了解释。

但是Java jocks将很高兴在这个版本中了解JDK支持。最初的Gradle插件专注于Java、Groovy和Scala,它仍然被认为是JVM的主要构建系统。

Gradle一直支持跨多种语言和平台的构建自动化,从Groovy、Java和Scala开始,现在包括Android和C/C++。该系统与几个开发工具和持续集成服务器紧密集成,包括Eclipse、IntelliJ和Jenkins。

Gradle团队为需要将较旧的Gradle 4.x版本迁移到Gradle 5.0的开发人员发布了详细指南。 (“请记住,对于任何从4开始的开发人员来说,都有一些重大的变化和需要考虑的问题,”他们写道。)GitHub上还有一个安装指南,供想要开始使用Gradle的新开发人员使用。

原文来自:https://www.linuxidc.com/Linux/2018-12/155621.htm

本文地址:https://www.linuxprobe.com/gradle-5-0-java-11.html编辑:周晓雪,审核员:逄增宝