Gradle 5.2.1 已经发布,Gradle是一个构建工具,专注于构建自动化和对多语言开发的支持。如果您在任何平台上构建,测试,发布和部署软件,它提供了一个灵活的模型,可以支持整个开发生命周期,从编译和打包代码到发布网站。它旨在支持跨多种语言和平台(包括Java,Scala,Android,C/C++和Groovy)的构建自动化,并与开发工具和持续集成服务器(包括Eclipse,IntelliJ和Jenkins)紧密集成。

高度可定制 - Gradle以一种可以以最基本的方式定制和扩展的方式建模。

快速 - Gradle通过重用先前执行的输出,仅处理已更改的输入以及并行执行任务来快速完成任务。

功能强大 - Gradle是Android的官方构建工具,并支持许多流行的语言和技术。‘’

v5.2.1 更改日志
此错误修复版本包含对Gradle 5.2的一些更改,特别是:

  • 单个源文件的Checkstyle问题:#8394
  • BOM支持冲突:#8420

我们建议您使用Gradle 5.2.1而不是5.2。

升级说明

通过更新您的包装器属性,切换您的构建以使用Gradle 5.2.1:

./gradlew wrapper --gradle-version = 5.2.1

原文来自:https://www.linuxidc.com/Linux/2019-02/156812.htm

本文地址:https://www.linuxprobe.com/gradle-521-release.html编辑:清蒸github,审核员:逄增宝

Linux命令大全:https://www.linuxcool.com/