导读 Python 2.x即将结束生命,英国国家网络安全中心(NCSC)敦促开发人员尽快从Python 2.x迁移到Python 3.x。越快越好。Python 2.x将于2020年1月1日停止使用,并且将不再提供bug修复和安全更新。

NCSC警告说,如果继续使用Python 2.x开发的模块,你将处于危险之中,因为漏洞总是会发生,新的漏洞不会被修复。

“如果你维护一个其他开发者依赖的库,你可能会阻止他们更新到3,”该机构补充说。“阻碍其他开发人员的开发,就间接地、很可能在无意中增加了其他人的安全风险。”

“在NCSC,我们总是强调修补的重要性。这并不总是那么容易,但修补是保护技术最基本的事情之一,“该机构说。

“WannaCry勒索软件提供了一个经典的例子,说明如果运行不受支持的软件会发生什么,”它说。 “通过决定在其生命周期结束后继续使用Python 2,您将接受使用不受支持的软件带来的所有风险,同时知道有一个安全的版本可用。”

原文来自:https://www.linuxidc.com/Linux/2019-08/160355.htm

本文地址:https://www.linuxprobe.com/ncsc-update-python-2.html编辑:周晓雪,审核员:张文祥

Linux命令大全:https://www.linuxcool.com/